---
title: "Troubleshooting Gmail Integration & Notification Issues"
description: "This troubleshooting guide helps you identify and resolve common Gmail integration errors and notification issues to ensure your notification workflow remain..."
url: "https://help.staticso2.com/user-integrations/google-calendar-connection/troubleshooting-gmail-integration-notification-issues"
---

This troubleshooting guide helps you identify and resolve common Gmail integration errors and notification issues to ensure your notification workflow remains uninterrupted.

***

## Gmail Service Disabled by Admin

[Section titled “Gmail Service Disabled by Admin”](#gmail-service-disabled-by-admin)

### Symptoms:

[Section titled “Symptoms:”](#symptoms)

* The User (Administrator/ Member) will receive an error notification when their Gmail mailbox is disabled by IT and a guest email is triggered.
* Guests will stop receiving any booking-related email notifications.

### Cause:

[Section titled “Cause:”](#cause)

The Gmail service is disabled for the user (or their Organizational Unit) at the **Google Workspace Admin console level**. When Gmail is disabled, OnceHub cannot access the user’s Gmail account, which is required for sending email notifications. If the Google Calendar was already connected, the integration remains active, but email sending is blocked.

### Resolution:

[Section titled “Resolution:”](#resolution)

To fix this issue, the Google Workspace Administrator responsible for managing mailbox settings should follow these steps:

1. Go to the [**Google Admin console**](http://admin.google.com/).
2. Navigate to **Apps → Gmail**.
3. **Enable Gmail** for the desired organizational unit or group.

***

## Gmail is Not Enabled for the Connected Account

[Section titled “Gmail is Not Enabled for the Connected Account”](#gmail-is-not-enabled-for-the-connected-account)

### Symptoms:

[Section titled “Symptoms:”](#symptoms-1)

* The User (Administrator/Member) will receive an error notification if the mailbox is not linked to their account.
* Guests will stop receiving any booking-related email notifications.

### Cause:

[Section titled “Cause:”](#cause-1)

The account was created using a **non-Google domain** (e.g., @[outlook.com](http://outlook.com)) and does not have the Gmail service enabled.

### Primary Resolution: **Disabling the Gmail Integration**

[Section titled “Primary Resolution: Disabling the Gmail Integration”](#primary-resolution-disabling-the-gmail-integration)

1. Click on your **Profile icon** in the top-right corner of the OnceHub account.
2. Select **User Integrations** from the dropdown menu.
3. Locate and click on the **Google Workspace** connection block.
4. Find the **Gmail toggle** and switch it to the **OFF** position.

### Secondary Resolution: **Link a Gmail Account**

[Section titled “Secondary Resolution: Link a Gmail Account”](#secondary-resolution-link-a-gmail-account)

If a user prefers to use native Google services, they can link a new **@gmail.com** address. Follow the steps below for the same:

1. While signed into your Google Account, click the **App Launcher icon (9-dot grid)** in the top-right corner of your browser.

2. Click the **Gmail** icon. Since your account uses a non-Google domain, this will automatically redirect you to the [**Gmail Service Setup page**](https://accounts.google.com/AddMailService).

   Note

   **NOTE:** If you are already signed into multiple accounts, it is best to do this in an **Incognito** **window** to ensure you are modifying the correct account.

3. Follow the on-screen prompts to choose your new **@gmail.com** address and link it to your existing account.
